Migrare a Joomla! 1.5

Mi sono finalmente decisa a fare la mia prima migrazione da Joomla! 1.0.x a 1.5.x, scegliendo opportunamente un sito in lavorazione pressochè privo di componenti aggiuntivi. Non mi dilugo sulle modalità usate, dato l’ampio numero di tutorial online (fra tutti però segnalo la guida ufficiale, quella di Joomla! Italia e questa, per le numerose immagini a supporto).

Tutti quelli che ho letto, però, si fermano alla creazione della versione migrata in una sottocartella, che porta ad avere di fatto due siti, quello in http://www.dominio.xx e quello in http://www.dominio.xx/cartella.

Una volta fatti tutti gli aggiustamenti sulla versione migrata (installazione template, componenti, moduli, plugin, …) in modo da ottenere nuovamente un sito funzionante e conforme all’originale, basta cancellare tutti i file della vecchia installazione, spostare tutto il contenuto della sottocartella di Joomla! 1.5 in radice e modificare il file configuration.php nelle due righe var $log_path e var $tmp_path, togliendo dal percorso l’indicazione della sottocartella.

6 Responses to “Migrare a Joomla! 1.5”


  1. 1 Emilio 29 luglio 2008 alle 11:48 pm

    Per dire la mia, ne sto proprio creando un sito con Joomla 1.5.3. Queste informazioni mi andranno bene per quando mi deciderò di cambiare quello che ho.
    Grazie Tania

    Domanda: con quale versione di PHP hai testato Joomla 1.5?

  2. 2 Tania Fabrello 30 luglio 2008 alle 12:00 am

    L’ho installato su PHP 4.4.7, purtroppo… Il purtroppo non deriva da dei problemi incontrati, ma dal fatto che l’hosting che uso non mette a disposizione PHP 5, ormai indispensabile per certi componenti.

    Ciao!

    P.S. Controlla la versione di Joomla: giusto l’altro ieri è uscita la 1.5.5.

  3. 3 Emilio 2 agosto 2008 alle 6:12 pm

    Ho capito, almeno credo.
    L’hosting che ho e credo che sia uguale al tuo, acquistato circa 2 anni fa’ è il seguente:
    Sistema Operativo Linux …. i686
    Webserver Apache/2.0
    Versione Php 4.4.7
    Versione MySQL 5.0.62-log

    Il sito che sto’ attualmente creando con Joomla 1.5.3, ha lo stesso fornitore dell’hosting, acquistato un mese fa’, ma con queste carateristiche:
    Sistema Operativo Linux …. i686
    Webserver Apache/2.2
    Versione Php 5.2.6
    Versione MySQL 5.0.62-log

    Conclusione: se voglio passare a versioni aggiornate di Joomla, Mambo, ecc., e avere tutte le funzioni, dovrò andare a scuotere l’hosting per aggiornarsi🙂

    Grazie e ciao!

  4. 4 Emilio 26 agosto 2008 alle 8:10 pm

    Mi sono accorto solo adesso che l’hosting mi ha aggoirnato la versione di PHP

    Sistema Operativo Linux … i686
    Webserver Apache/2.2
    Versione Php 5.2.6
    Versione MySQL 5.0.62-log

    Bene, dico bene perché non ho scuoiato l’hosting.😀

    Ciao!

  5. 5 Tania Fabrello 19 settembre 2008 alle 10:31 am

    Nell’area assistenza del nostro comune provider trovi la notizia del 28/06/08 “PHP:Upgrade dalla versione PHP4 alla PHP5” che dice

    Abbiamo il piacere di informare tutti i clienti che usufruiscono dei nostri servizi Hosting Windows ed Hosting Linux che sta iniziando l’operazione di upgrade da PHP4 a PHP5 su tutti i server attivi. Verra’ inviata ad ogni cliente una e-mail contenente la data di upgrade prevista per il server su cui risiede il proprio dominio: il preavviso minimo sarà di un mese

    Finalmente!
    Per un nuovo hosting ho richiesto espressamente di essere messa su un server con PHP5 e mi hanno accontentata🙂

  6. 6 Giulio 22 settembre 2009 alle 5:36 pm

    Ciao,

    sapete se il passaggio sui server hosting da php4 php5 e Mysql 5, può creare problemi su un blog wordpress?

    Nel caso come comportarsi?

    Grazie per la risposta,

    Giulio


Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...




Aggiornamenti Twitter


%d blogger cliccano Mi Piace per questo: